BETA

14th January 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/01/18 03:38 PM] with 'Major Outage'

Issue has been resolved at [14/01/18 03:39 PM]