BETA

14th January 2018

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [14/01/18 03:32 PM] with 'Major Outage'

Issue has been resolved at [14/01/18 03:39 PM]