BETA

14th January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/01/18 03:28 PM] with 'Major Outage'

Issue has been resolved at [14/01/18 03:29 PM]