BETA

16th March 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [16/03/17 01:46 AM] with 'Partial Outage'

Issue has been resolved at [16/03/17 01:51 AM]