BETA

15th March 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [15/03/17 11:00 AM] with 'Partial Outage'

Issue has been resolved at [15/03/17 11:01 AM]