BETA

14th January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/01/18 02:58 AM] with 'Major Outage'

Issue has been resolved at [14/01/18 02:59 AM]