BETA

13th January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/01/18 03:00 PM] with 'Major Outage'

Issue has been resolved at [13/01/18 03:02 PM]