BETA

10th January 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [10/01/18 12:09 AM] with 'Major Outage'

Issue has been resolved at [10/01/18 12:10 AM]