BETA

14th March 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [14/03/17 02:49 PM] with 'Partial Outage'

Issue has been resolved at [14/03/17 02:50 PM]