BETA

5th January 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [05/01/18 08:05 PM] with 'Partial Outage'

Issue has been resolved at [05/01/18 08:07 PM]