BETA

14th March 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [14/03/17 01:33 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/03/17 01:35 PM]