BETA

14th March 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [14/03/17 09:42 AM] with 'Partial Outage'

Issue has been resolved at [14/03/17 09:44 AM]