BETA

17th February 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [17/02/17 01:29 PM] with 'Major Outage'

Issue has been resolved at [17/02/17 01:35 PM]