BETA

14th February 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/02/17 12:05 PM] with 'Major Outage'

Issue has been resolved at [14/02/17 12:06 PM]