BETA

4th January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [04/01/18 09:52 PM] with 'Major Outage'

Issue has been resolved at [04/01/18 09:53 PM]