BETA

4th January 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [04/01/18 05:23 AM] with 'Partial Outage'

Issue has been resolved at [04/01/18 05:24 AM]