BETA

4th January 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [04/01/18 03:22 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [04/01/18 05:18 AM]