BETA

4th January 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [04/01/18 03:22 AM] with 'Partial Outage'

Issue has been resolved at [04/01/18 03:24 AM]