BETA

9th February 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [09/02/17 12:58 AM] with 'Partial Outage'

Issue has been resolved at [09/02/17 01:03 AM]