BETA

3rd January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [03/01/18 10:28 AM] with 'Major Outage'

Issue has been resolved at [03/01/18 10:29 AM]