BETA

31st December 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [31/12/17 09:21 AM] with 'Partial Outage'

Issue has been resolved at [31/12/17 09:24 AM]