BETA

31st December 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [31/12/17 09:20 AM] with 'Major Outage'

Issue has been resolved at [31/12/17 09:32 AM]