BETA

31st December 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [31/12/17 03:15 AM] with 'Major Outage'

Issue has been resolved at [31/12/17 03:17 AM]