BETA

31st December 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [31/12/17 03:12 AM] with 'Partial Outage'

Issue has been resolved at [31/12/17 03:15 AM]