BETA

29th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/12/17 03:14 PM] with 'Major Outage'

Issue has been resolved at [29/12/17 03:15 PM]