BETA

29th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [29/12/17 01:25 PM] with 'Major Outage'

Issue has been resolved at [29/12/17 01:26 PM]