BETA

26th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [26/12/17 06:39 PM] with 'Major Outage'

Issue has been resolved at [26/12/17 06:40 PM]