BETA

7th February 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [07/02/17 11:54 AM] with 'Partial Outage'

Issue has been resolved at [07/02/17 11:55 AM]