BETA

26th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [26/12/17 06:39 PM] with 'Partial Outage'

Issue has been resolved at [26/12/17 06:40 PM]