BETA

26th December 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [26/12/17 04:21 PM] with 'Partial Outage'

Issue has been resolved at [26/12/17 04:22 PM]