BETA

26th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [26/12/17 02:14 PM] with 'Major Outage'

Issue has been resolved at [26/12/17 02:15 PM]