BETA

20th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [20/12/17 09:27 PM] with 'Partial Outage'

Issue has been resolved at [20/12/17 09:28 PM]