BETA

20th December 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [20/12/17 09:26 PM] with 'Partial Outage'

Issue has been resolved at [20/12/17 09:27 PM]