BETA

18th December 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [18/12/17 12:59 PM] with 'Major Outage'

Issue has been resolved at [18/12/17 01:00 PM]