BETA

18th December 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [18/12/17 12:56 PM] with 'Partial Outage'

Issue has been resolved at [18/12/17 01:00 PM]