BETA

17th December 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [17/12/17 11:47 AM] with 'Partial Outage'

Issue has been resolved at [17/12/17 12:02 PM]