BETA

7th February 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [07/02/17 05:39 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [07/02/17 06:04 AM]