BETA

17th December 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [17/12/17 09:38 AM] with 'Major Outage'

Issue has been resolved at [17/12/17 09:39 AM]