BETA

17th December 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [17/12/17 01:49 AM] with 'Partial Outage'

Issue has been resolved at [17/12/17 01:50 AM]