BETA

16th December 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [16/12/17 02:32 AM] with 'Partial Outage'

Issue has been resolved at [17/12/17 01:47 AM]