BETA

15th December 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [15/12/17 10:21 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 10:22 PM]