BETA

15th December 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [15/12/17 10:21 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/12/17 12:23 AM]