BETA

15th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/12/17 08:13 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 08:14 PM]