BETA

15th December 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [15/12/17 08:11 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 08:20 PM]