BETA

15th December 2017

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [15/12/17 07:22 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 07:23 PM]