BETA

15th December 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/12/17 05:25 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/12/17 08:08 PM]