BETA

15th December 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [15/12/17 05:14 PM] with 'Major Outage'

Issue has been resolved at [15/12/17 05:15 PM]