BETA

15th December 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [15/12/17 04:19 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 05:11 PM]