BETA

15th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [15/12/17 03:39 PM] with 'Partial Outage'

Issue has been resolved at [15/12/17 03:40 PM]