BETA

15th December 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [15/12/17 03:31 PM] with 'Major Outage'

Issue has been resolved at [17/12/17 01:51 AM]